IMS User Registration Impacted by AWS Outage

Incident Report for Bentley Systems, Inc

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 23:07 UTC

Update

We are continuing to work on a fix for this issue.
Posted Oct 20, 2025 - 17:05 UTC

Identified

Due to an ongoing AWS outage, our IMS user registration process is currently unable to send verification emails. As a result, new user registrations will not complete successfully until the issue is resolved. We appreciate your patience and will provide updates as they become available.
Posted Oct 20, 2025 - 17:03 UTC
This incident affected: Identity Management Systems (IMS) (Authentication / Login, User Management).