Intermittent accessing issue on iModels in PlantSight: US East Region

Incident Report for Bentley Systems, Inc

Resolved

We’ve been monitoring for an extended period and haven’t observed any issues. We’ll go ahead and resolve the case now. Thank you.
Posted Oct 29, 2025 - 10:52 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 28, 2025 - 23:39 UTC

Identified

The issue has been identified, and our team is actively working to implement a fix soon to resolve it.
Posted Oct 28, 2025 - 22:16 UTC

Investigating

Our team is currently investigating an issue accessing projects on iModels in PlantSight.
Some users may be having trouble using certain features.
In the meantime, we apologize for any inconvenience this may cause and appreciate your patience and understanding.
Posted Oct 28, 2025 - 21:28 UTC
This incident affected: iTwin Products (PlantSight) and iTwin Platform (iModels, Projects).