Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 24, 2025 - 16:00 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Oct 24, 2025 - 15:26 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Oct 24, 2025 - 15:16 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Oct 24, 2025 - 14:19 UTC
Scheduled
Bentley will be doing certificate maintenance on across a large number of web sites starting Friday, October 24 at 16:00 UTC and expect to be done the work by Saturday, October 25 at 16:00 UTC. Users may see certificate errors accessing sites during this time. Each site should only be impacted for a short time but it will take time to roll across all site.
During this time, the following services may be intermittently unavailable.
Friday 1600 UTC 'BCSM Production', 'BentleyConnect Production CIN', 'BentleyConnect Production JPE', 'BentleyConnect Production SEA', 'BentleyConnect Production AU',
Friday 19:00 UTC 'BentleyConnect Production SAN', 'BentleyConnect Production WEU', 'BentleyConnect Production UKS', 'BentleyConnect Production NEU',
Saturday 06:00 UTC 'Connection Center Production EUS', 'BentleyConnect Production', 'IMS Production', 'BentleyConnect Production CAC', 'The One Production'
We apologize for any inconvenience this may cause and appreciate your patience as we work to improve our system.
Thank you for your understanding.
Posted Oct 24, 2025 - 13:57 UTC
This scheduled maintenance affected: Base Services (Bentley Communities, Bentley.com, CONNECT Center, Education, Learn, Managed Services (Global Status), Phone System, Product Documentation, Software Downloads, Support Portal, URL Directory Service (BUDDI), Virtuosity Digital Storefront).