Bentley Education Site: Login Issue

Incident Report for Bentley Systems, Inc

Resolved

This incident has been resolved, and the Bentley Education sites are now working normally.
Thank you for your cooperation.
Posted Jan 27, 2026 - 11:20 UTC

Investigating

Our team is currently investigating the issue and working to resolve it. Some users may experience difficulties login to the Bentley Education site.

We are working diligently to identify the root cause and implement a solution. We will provide updates as we learn more.

In the meantime, we apologize for any inconvenience this may cause and appreciate your patience and understanding.
Posted Jan 27, 2026 - 10:51 UTC
This incident affected: Base Services (Education).