IMS Connection issue: US Region

Incident Report for Bentley Systems, Inc

Resolved

Our team acted quickly to restore full functionality to IMS, and a fix has been implemented. All services should now be operating as expected. Thank you.
Posted Oct 30, 2025 - 12:37 UTC

Investigating

Our team is currently investigating an issue with IMS. Some users may be having trouble with connection.
We are working diligently to identify the root cause of the problem and implement a solution. We will provide an update as we learn more.
In the meantime, we apologize for any inconvenience this may cause and appreciate your patience and understanding.
Posted Oct 30, 2025 - 12:29 UTC
This incident affected: Identity Management Systems (IMS) (Authentication / Login, User Management).